Failed To load built-in database drivers when running knime from eclipse

I’ve developed a new node extension. For testing purposes I followed this link. but the problem is that none of the built-in jdbc drivers (e.g, Postgres, MySql and etc) are not loaded. I want to test my node with DB connectors.
As you can see in below picture, the driver name drop down in empty. Also I register my own driver for Postgres according to this link but nothing changed.


  • Ubuntu 22.04 LTS - Windows 11
  • Knime Analytics Platform (4.7 release)
  • complete target platform (branch release/2022-12)

Error Logs:
knime-error.txt (3.9 KB)
eclipse-error.txt (37.0 KB)

Hello nmorti,

Thank you for posting about this issue. Would you mind trying to update KNIME to a newer version and seeing if the problem still persists?

Thank you for your time and cooperation.

Best regards,

1 Like

Hi @jinwei_sun ,
I’ve tried with branch releases/2023-03 which is early access of knime 5.1.0 but got the same result. master branch is unstable and it’s not suitable for test. (you can see this link)

Hey Nomrti,

We apologize for the continued inconvenience you are experiencing. Rest assured that we have escalated your concern to our team of experts who specialize in resolving this particular issue. They will diligently provide you with a solution as soon as possible. Thank you.

Best Regards,

Hi @nmorti,

Can you check if you have the database extensions in your target platform?
If you use the knime-sdk-setup/ at master · knime/knime-sdk-setup · GitHub target platform they should be included.


Hi @gab1one,
I’ve checked the target platform which you mentioned with mine and I didn’t see any strange differences.
In addition, it’s expected that drivers can be loaded with stable releases in branches releases/*
I had some problems with master branch

This is my target platform:
KNIME-AP-complete.txt (10.7 KB)

Hi @nmorti,

I can reproduce this issue on my development setup. I will figure out how to get this working by checking back with our developers for this feature.


Hi @nmorti,

You need to add the following lines to the vm arguments in your launch configuration:


I have updated the knime-sdk-setup, so that these values are now set correctly in the launch configuration shipped in that repository.



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.