Fatal error and workspace couldnt be saved

Hi,

while trying to save any of my three open workflows I got this message:

 

File access problems: /var/folders/3+/3+bZ1tbnFYyIMc4STi2l1U+++TM/-Tmp-/knime_ArrayScan_KPIsc70779/knime_container_20130826_2587661379612098194.bin.gz (No such file or directory)

...and the console:


FATAL     SaveWorkflowRunnable     File not found
ERROR     WorkflowEditor     Could not save workflow: File access problems: /var/folders/3+/3+bZ1tbnFYyIMc4STi2l1U+++TM/-Tmp-/knime_ArrayScan_KPIsc70779/knime_container_20130826_2587661379612098194.bin.gz (No such file or directory)

 

I checked this folder later and I couldnt find the folder "knime_ArrayScan_KPIsc70779". Was some temp data lost here? I couldnt save any workflow and lost the changes. I had my computer and KNIME on for some days without working on these workflows.

 

Another thing I also noticed is this error, which I got just before and was the reason for saving and restarting KNIME:

 

2013-09-05 13:45:35,361 DEBUG main StringManipulationSettings : Include jar file: /Applications/knime/plugins/org.knime.jsnippets_2.8.0.0038667/lib/snippet_inc/commons-lang3-3.0.1.jar
2013-09-05 13:45:35,549 DEBUG main JavaCodeCompiler : Error output of compilation:

 

...this type of error sometimes happens to me in String Manipulation nodes or Java Snippet (Simple). Then an error occurs upon OK (and check syntax on close on). The syntax nevertheless is ok, usually I then set check off, close, save, restart KNIME, go back and open that node, check on, and everyting is ok. So KNIME couldnt interpret the syntax anymore, restart solved it. This behaviour, I have the impression, occurs also if I worked already for some time (days) without restarting KNIME. Maybe also a temp data thing?

 

I uploaded the some of the knime.log

Thanks for help,

Martin

 

This can happend if some background/cron job deletes data from your temp directory. Can you check whether this is the case on your system?

I have double checked with our computer department and I have searched the web a bit. I think there is no chron job that deleted temp data (and MAC OS doesnt either as far as I know).