Fatal error when start KNIME 2.4.2 on Linux (Fedora)

OS:Fedora release 16

I meet a JAVA fatal error when I start KNIME 2.4.2 on my Linux (when loading workbench).

On the same machine, I can run Eclipse_KNIME 2.4.2 very well.

Do I need any special setting for KNIME 2.4.2?

Please check the attached error log file.

I would appreciate your suggestion.

Thanks

Alex

The problem is probably the version of xulrunner which is installed on your system. It seems xulrunner-2 is incompatible with Eclipse 3.6. You can try to install an older version of xulrunner (1.9) and then add

-Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner-1.9

at the end of the knime.ini (adjust the path). You will very likely get the same error in eclipse_knime as soon as you open a view/window that displays an HTML page (e.g. the Eclipse help).

 

Thank you for your reply.

I installed xulrunner 1.9 and modified KNIME.ini.

Now it works well.

Good to here! Can you tell from where and how you installed the xulrunner-1.9? Then we can make a FAQ entry for all affected users.

I just find FAQ's first answer is for me. LOL

You can find the download from the following url:

http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/1.9.1.19/runtimes/

(1)download

(2)unzip the file

(3)modified KNIME.ini

I didn't uninstall xulrunner 2.0, cuz not sure whether others app use it.

I see. I thought/hoped that there was an RPM available. The xulrunner from Mozilla does not seem to be available in 64Bit.

is there a package for 64 bit ready by now?

 

I don't think so, but http://tech.knime.org/faq#q6 may help you, too.