Feature Calculator BETA doesn't allow configuration

Hi all,

I'm trying to use the Feature Calculator node but I I can't not get the configuration window to show up, when I click configure nothing happens. Any idea why this happens?

Thanks in advance.

Hi dcorujo,

Thank you for reporting this bug, to accurately determine it's cause we need some information from you. Can you please tell us which operation system you are on and which KNIME / KNIP version you are using? Also if you can attach the KNIME log after you tried opening the Feature Calculator Node  to your answer, it would help us a lot.

You can find the KNIME log in the menu: View -> Open KNIME log.

best,

Gabriel

PS: You can try switching to a new Workspace, this sometimes helps with such issues.

Hi gab1one,

I tried switching to a new Workspace but the same issue remains.

I'm running Windows 10, KNIME v3.1.2 and what I believe is the nightly build of KNIP ( "KNIME Image Processing    1.4.2.201606230637" as shown in Installation Details).

I attach the log file after executing the node (although I can not configure it). It seems that nothing appears in the log when I try to configure the node (neither clicking the menu or pressing F6). At the end I inserted an Image Feature Calculator node to the workflow, in case it can give any hint.

Thanks.

edit: I tried reinstalling the whole KNIP but I'm still having this problem.

Hi Dcorujo,

we will have a look and test it on Windows 10. Until then you could use the Image Segment Feature or Image Feature or Segment Feature nodes which cover most of the functionality of the Feature Calculator (BETA).

Best,

Christian

Thanks, I was particularly interested in the 3D measurements (Geometry and Haralick), is there another way to easily get this features in 3D? 

Alright, we found the problem and will fix it. Should be working tomorrow! Sorry for the trouble (sometimes this happens with the nightly build :-( ).

Best,

 

Christian

Hi,

I was able to fix the bug and just manually started the nightly build. If everything works well, you will be able to use the node tomorrow. Let me know if you face any further problems.

Christian

Thanks a lot for your help, I downloaded the latest nightly and indeed now the Feature Calculator works well, I can configure and execute it without issues. However another problem has appeared, this time with the Image Reader node. When I execute it the console reads "encountered errors during execution" and no images are actually read. It looks like the path to the image file is not read correctly and thus it is unable to find the files, the "\" in the path are converted to "%" (not sure if this is intended but don't remember seeing it before). I attach the log after trying to read images.

Thanks again and please tell me if I should open a new thread for this issue.

Hi,

We are currently changing some stuff in the image reader, that’s why problems may occur on the nightly. Thanks for reporting! I will try to fix it today or tomorrow!!

Christian

Hi,

thanks again for reporting the issues. I was able to fix it. I'm currently building the nightly-build, so you should be able to update KNIME in 1.5h.

Thanks again!

Christian