File location not working for examples in 4.4

Hi,
I upgraded to knime 4.4 and the data of the example is not working anymore. All I get is input file does not exist. I had a look through " File location not working for examples in 4.2" and tried out some of the comments but nothing worked.

image

Regards
Pio

you are using the previous version of the table reader. have you tried with the new one?

Hi @iperez


I have tried the new one but still can’t get it to work

Hello @pio,

are you talking about workflow example from KNIME Hub/EXAMPLES Server or this is your workflow?

Br,
Ivan

Hi @ipazin
This is workflow example that I downloaded from the KNIME Hub/EXAMPLES

Regards
Pio

@pio can you share the link of the workflow with us?

Hi Iris,

This is the link
knime://knime.workflow/…/_data/satimage.table

Regards
Pio

If you want to use KNIME URL you have to change the “Read from” from “Local File System” to “Custom/KNIME URL”.

Edit:

Besides that “knime://knime.workflow/…/_data/satimage.table” somehow seems to be incorrect anyway since the “…” would mean you are in your workspace directory. So your workspace directory should have a “_data” directory in it.

3 Likes

Hello @pio,

can you say which workflow is it? Or share a workflow link with us? That’s what @Iris had on mind when asking for link :wink:

Br,
Ivan

2 Likes

Hi @Iris @ipazin
Thanks for the clarification.
Here is the workflow
04_call_workflow_(Table).knwf (18.1 KB)

Regards
Pio

Hello @pio,

so it’s about this workflow:

You only downloaded workflow whereas data the Table Reader is trying to import is one level up. So go one level up (02_Call_Workflow_and_REST) and there you can see _data folder together with possibility to download entire group of workflows (bottom picture). Once you do that Table Reader will be able to read data normally.

Additionally besides workflow download option you can click Open and that will open workflow from EXAMPLES server and that workflow can access above mentioned _data folder or any other properly referenced (see picture).

And last but not least as @laaaarsi said to use current (not deprecated) Table Reader with KNIME URL use Custom/KNIME URL option in configuration dialog.

Br,
Ivan

4 Likes

Thanks @ipazin @Iris @laaaarsi @iperez for the help. Sorted now

4 Likes

Glad to hear that @pio.
Ivan

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.