File reader - error message : Too many data elements

Dear Knime community


I would need your help to enable file reading of CSV via file reader under loop functionality. 

It shows error message - execution failed : Too many data elements (line:2(Row0)) for some files under loop variables. However, when I tried this single file to read via file reader  (without loop), it worked well and didn't show any error. May I know if this is some issues under loop design via variables or file itself ? Strange thing is that if just only file reader, it doesn't show any error.. .appreciate your support ! 


Thanks and regards


The file that gives you the errors has probably different stracture from your template table.

in a project that I work on it occourd because of one file that had one row that conatained two entries in one row.

my way of fixing it (not ideal) was to edit the template table so it will extra columns and after that I would filter those columns.

Hello everyone,

i'm fairly new to knime and i'm having the same problem as Miki. This is a brief description of what I'm trying to do. I'm using the file reader to load a csv file into an x-partioner for classification. When I run in batch mode and I load a file with more columns than I did in design mode I get the error "too many data elements". How can I fix this and what will be good alternatives to file reader that will allow me to load variable file structures? I tried CSV reader, but that does not output a datavalue object and so x-partioner will not work with it.

Any help will be greatly appreciated.




Could it be a problem about how to close the loop?If you use a regular end-loop the table structure may differ from each loop. You can try to add the rows in a different file (inside the loop, with a csv writer, with add rows option checked) and close the loop via flow parameters conection (red ones). Then you would have your data in only 1 file to continue your proccess.





Hi Miki,

I have the same problem, did you find a solution eventually?

Looped file reader not working, not-looped working's so weird.

Hope you can help!

Thanks in advance,