Force a Column Type to String


I am struggling with my worflow in order to set a column datatype from "Data Value (?)" to "String"... 

The problems is that I'm looping through a list of files, some of them have every column populated and some others have null columns. At the second iteration the Loop End node fails with "<Column_Name_x> data type has changed"... For me it's OK to set everything as String, but I cannot find a way to do it..

Any ideas? 

I tried to use a Java Snippet node, but it sets the Type for input data, so the issue still remains...

Thanks in advance.


Hi Angelo,

since 2.11 (I think), the Loop End nodes have options called "Allow variable column types", which should be doing what you need. It's just the "regular" loop ends though, neither the Vernalis nodes from the community contributions nor the other base nodes have these options, as far as I know.

If that doesn't solve your problem, maybe one of the Table Validator nodes can help?

Hi Marlin,

thanks for the tip, it would be great but unfortunately I have to stay on 2.10 and there's no such option for End Loop node.

I managed to find a workaround by using a Table Writer + Table Reader. The writer node creates/insert data in a DB table where datatype is Varchar2 (Oracle) if columns are empty. Not elegant solution at all, but it seems to be working, maybe this will help someone else too ;)

Any smarter solution is welcome!

Thanks again,


Hi Angelo,

another possibilty is to use the line reader. The Line reader would be inside the loop and right after the loop end you can use a cell splitter to get individual columns.

Cheers, Iris