GBQ DB Query Reader failure

Hi Guys,

I’ve got an issue with reading from GBQ via knime. The service account seems fine, I’ve changed the ‘Database name’ in the Google BigQuery Connector several times when trying to query a table. All of them work until I try pulling 40k or more records.

I tried running the same query, changing the database every time and the error message refers to the same user.

What’s strange is that writing to Google BigQuery, I also get failure messages until I select the ‘correct’ database name. The DB Reader and writer are connected to the exact same Google BigQuery Connector. The write ends up being successful, but the read fails.

I’m out of ideas since one query works but the other fails. Ideas anyone?

Thank you

Hi @Albert123,

are you running your workflow in a company network?
To me this sounds like a network proxy or firewall that block transfers over a certain size.

Kind regards
Marvin

Hi @marvin.kickuth,

Turns out the ‘readsessions.create’ permission wasn’t granted.

Once granted, the flow worked perfectly fine. It was strange that queries would execute at up to 40k records.

The permission denied message appears for queries from 40k upwards. Surprisingly this doesn’t affect writing data to GBQ, only affects reading info from.

Thank you.

2 Likes