GeoFile Writer fails, not sure why

Geofile Writer does not finish it’s task, sinalises an error, but not what the error is.
I configured it to write in my local files (in the same folder where it reads it from, so it does have access). I’m not sure if I configured it the right way? I’ve tried both shapefile and geojson output and also with and without extensions after the file’s name

1 Like

Hello @Magali,

Thank you for your posting your query. What you are doing is ideally the correct way to write the GeoFile. The selection of output file format should automatically append the desired extension upon writing the file. Can you share console output of your workflow? Also, out of curiosity, did you try writing it to any other path? Might be that user read/write privileges are conflicting here.


1 Like

Hello @Magali ,
if you still have this problem can you please have a look into the KNIME log file (View->Open KNIME log) and send us the error message which should be at the end of the log file once you have executed the node.


Dear Ali and Tobias,
Thank you for your reply.
I tried again using a different path and both formats but I still get an error:
“ERROR GeoFile Writer 3:14 Execute failed: Cannot interpret ‘<geopandas.array.GeometryDtype object at 0x000001BDD0AB4E80>’ as a data type”

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Hello @Magali,
we have just release version 1.1 which might have fixed your problem. Can you please give it a try and report here if the problem still persists. If it still fails could you please provide us with an example workflow to reproduce the problem.

For more details about the release click here.