GETRequest with wrong output

Hello,

I just started Knime and run into a problem.
I created the following Workflow:

I tried with a dynamic URL to get the Data from OData Rest-API. My problem now is, that when starting the GetRequest the light gets green but it only shows the generated URLs in the first colums. not the desired Data.
The credentials of the OData have been put into the GetRequest under authorization → Basic.

What can I do about this Problem

Kind regards
K

Hi
get request should normally give you more columns
e.g. a 200 response and the response html or json
you only see the url in the output?

br

Hello,
this is my GET results, I had to censor some parts, company rule, sry.

When I put the URL into my browser, it gives out all Data sets I’m looking for, but not for Knime

In order to help I think it’s safe to say we need to see how your Get Request node is configured :wink:

2 Likes

Hello,
the only parts of the configuration of the GET Request would be ‘Connection’ and ‘Authentication’.

Both in 4.7.7 and in 5.2.0 I get the desired result when using the public OData endpoint. I used default settings on the GET Request and only applied the URL Column.

If you have not done it already, I would recommend enabling the error handling. This might help you get closer to the root cause. Since you have two columns as output, I’m suspecting there is an actual error but it’s being converted to an empty value as per these settings.

I tried it and it gives me the following error message:
Execute failed: SSLHandshakeException invoking ‘https:URL-Path
PKIX path building failed:
sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

With this error Message my guess would be I need to talk to my IT-department regarding a certification/certification data.
Could it be an OAuth2/other Auth Node is missing?

I found in an other forum that I have to check the following:


Now it works, thank you all

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.