Google Analytics Connection - Can't connect to API

Hi Folks

Hoping someone might have some insight here.
Today i passe don a workflow to a client and was helping them setup knime and run the workflow.

The Google Authentication (API) works fine and we were able to connect to BigQuery without issue.

We then connected the Google Analytics Connection, however this fails to connect to the API.

The service account email is correct and has been given access in GA. In fact it works on my computer.

Scopes have also been set.

We switched off any firewalls etc… but still no luck

Can’t understand why it fails to connect.

If Devs or someone could give some insight as to possible reasons that would be great…


Hi there @Gavin_Attard,

same KNIME version, same OS systems? What is the error message you are seeing? Also have you checked KNIME log for more messages. Make sure to have log level output set to DEBUG for maximum info.



This is now fixed.

It turns out it had to do with sequencing. The project was opened prior to the extensions being installed.

When we re-imported the project, it worked straight away…

the things we learn…

1 Like