Google Authentication Node Issue

Hello,

I am having an issue with the Google Authentication node. In node configuration, after I hit “Authenticate” and select my Google Account it keeps spinning in “Auth in browser” but never finishes the authentication.

Any help resolving the issue would be much appreciated.
Thanks,
Marie

Could I ask:

  1. the version of KNIME you are using
  2. the browser you used
  3. the kind of computer you are using
  4. can you attach your workflow (I’d like to see if this error is workflow dependent or not)?

Thanks!

Thank you for your quick response. Please see answers to your questions below.

  1. Version: 4.2.2
  2. Browser: Google Chrome
  3. Computer: HP EliteBook 840 G6
  4. Workflow: I can’t send this particular workflow because it contains Headcount data but let me know if you would like some sample data. I don’t think it is workflow dependent because I tried it in another workflow and I’m still having issues.
  5. I tried Authenticating again today and now I’m getting the below error. I’m not sure if this helps.
    Error Message

Great,

Let’s rule out browser and KNIME Version next. Can you try changing your default browser to FireFox and if that also fails, can you then try to use a newer version of KNIME?

Hi @mariesylvia , on top of what @victor_palacios is asking you to test, are you able to authenticate into Google directly in a browser - that is not the one that Knime pops up, but just trying to authenticate without Knime (open browser, log into Google), but on the same system as where you are running Knime?

Google is very strict and does not take a chance if it does not know your device or if your system is out of date (system or browser).

1 Like

Hello,
My company does not give an option to have FireFox as the default browser but I downloaded to a newer
version on KNIME and I’m still having issues.
Also, I am able to open a browser and log into Google successfully but it is just not working with the Knime pop up. Is there anything else that I can try?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.