Google Authentification Error

I confirm that I followed the tuto without completing the internal/external section and the Google API connection is working fine.


Thanks, I could connect the Google Authentication (API Key), but not with the normal google authentication node. However, even though I was able to create and read a google sheet, I couldn’t see it at the google sheets interface. I need to show (to a class) the interactivity between google sheets and Knime, making a formula on google sheets, and read it again. Could you help me?

Tyler - sorry for the delayed reply - I do think it makes sense to make an adjustment to the blog, but this is my opinion. It is very easy to get stuck if you try to follow the path shown due to the fact that it might appear as though you are waiting for google to approve your connection-- we can connect directly if that is helpful

1 Like

Yes - you have to skip that part if you are a free user!

The problem is that if you’re using a service account, the account acts as a separate entity, so the Sheets you are writing won’t automatically be shared with your own account.

The workflow Share Spreadsheet To Account (KNIME 4.1) showcases how you can share a Sheet written to a service account with a list of other users.

1 Like

We have an update on the Google Authentication situation.

For Google Sheets and Google Drive, you should now be able to use the Google Authentication node again. For it to work you have to make sure to deselect the Google Analytics scopes in the node’s configuration dialog. Google applied some restrictions, so that authentication does not work when requesting the Google Analytics scopes at the moment.

For Google Analytics, for the time being, you have to continue using the Google Authentication (API Key) node.

Sorry for the inconvenience.


Will update it this weekend, thanks for the help.
Agreed on scopes being what you troubleshoot the most at the startup.

I would highly recommend developing all the ‘scope’ tools as necessary, label it, and never do it again.

I’ve unselected anything to do with Google Analytics. The have tried playing around with the various remaining selections. (Google Sheets Read, Google Sheets and Google Drive Read) and other single and double combinations - but it still doesn’t work.

Once I click authenticate it brings me to google sign in
I choose my account
Google then asks about permissions / access - I click allow
inside the browser it looks like it is working. “Received verification code. You may now close this window.”
i go back to knime and it gives me a timeout error. "Authentication failed. SocketTimeoutException: connect time out

please help :slight_smile:

1 Like

Welcome to the community @onizuka023.

The Authentication pass through doesn’t seem to work for me too. Above I posted about needing a gsuite account to setup the google authentication node, however I was incorrect and I’ve updated the blog.

You can use this to setup the google api authentication node, which will allow you to use these nodes regularly, without the authentication piece that I believe expires after a certain amount of hours.

Discussed here too. KNIME Google Authentication API Key Walkthrough


hi Tyler

I did the API setup but I get stuck on the - give the service account created access to the google sheets. My company does not allow the sharing of files outside of the company. And therefore the is blocked / not a whitelisted domain.

This is why I had to go the Google Authentication route.

Is there any other alternative? Why does this node not work as designed. / On older versions of KNIME it previously worked.


1 Like

That makes sense, sorry to hear about the environment problems. Sounds like your IT team needs to make an exception if this is the intended route for the environment. I would work with the head of engineering and ask if this is okay. Get approvals from the top and then request it be whitelisted.

Before meeting with decision makers, I like to have a POC available, to show the value and setup process if needed.

1 Like

Thought more about it, have you asked where the source of the data is coming from because I have a feeling that will remove this gsuite gate.

i think it’s more about KNIME and the node that works for some, but not for all. going the route of hey company change your policy is more difficult than KNIME fixing things on their end. I’m almost certain I’m not the only person who has an uphill battle with corporate. but my work around now is - google to excel, excel to db.

1 Like

When the adoption of database technology or document storage solutions only pushes users to developing solutions on google sheets and spreadsheets, then the solution isn’t adopted.

If you’re pushed "off platform " and your data validation is depending on people???

Spreadsheet development is a “high risk” and “low reward” service opportunity.

IMO the data validity of “human mistakes” is an easy topic to have with executives and IT.

I can see a good case to be made for “acid compliant solutions” and removing data validation concerns from the developers and analysts using the solutions.

Also, case can be made for your spreadsheets being a single point of failure when databases can live and survive without your computer open.

I would start with explaining ACID compliance to your boss if the corporate environment doesn’t allow for cross collaboration, for me being in analytics consulting for 10years, it’s easy to say “go to an decision maker with a better solution” because that’s how I drive the needle.

Hope this helps and I’m sorry if this doesn’t help. Sometimes learning about acid compliance is enough of a hammer to bring to your next scrum meeting. Acid compliance on a powerpoint slide is 1 slide and good to be able to explain to your managers when developing in the analytics industry, as acid compliance can be a save grace if everyone keeps handing you a spreadsheet… It helped me a lot, i hope it helps you.

thanks for the quick responses. i get that this isn’t the best option. but sometimes quick turn-around and ad hoc analysis is needed. getting everyone on board trying to capture data collaboratively to the specs of what an architect / db admin want isn’t ideal for the majority of employees who don’t understand the importance of structured- validated data. it isn’t enough of a reason for my overlords to say - open it up to service accounts for API connections.

hence - the need for the quick and dirty. knime / alteryx helps solves this data ingestion for regular folk who aren’t using python or intense programming languages.

i’m guessing KNIME doesn’t really provide responses here? or don’t intend to fix this node?

1 Like

@onizuka023 On the contrary - the dev team is aware of the difficulties folks are having with this node. No ETA on a possible update yet, but I did want you to know you’re being heard. :slight_smile:


thx! loving the tool so far. now to throw more work onto your team - a node that allows you to write to HDFS (perhaps insert statements one line at a time?)

1 Like

Hi onizuka023,
if mean Hadoop Distributed File System with HDFS this is already possible with the free KNIME Big Data Connectors which are part of the KNIME Big Data Extensions. You can also just search on the KNIME Hub for HDFS to find example workflows and the nodes.

1 Like

So the authentication is actually working. But your Analytics Platform is not receiving the credentials. Could you provide the knime.log for that SocketTimeoutException?

From a distance it seems like it might be a network issue.


reading the error log - it looks like it’s trying find a folder that doesn’t exists.
maybe it’s where i have the workflow saved vs. where the platform was installed?
also - i should say i have no clue how to fix this. PLEASE help :slight_smile:

let me know if this excerpt helps…

2020-04-03 14:41:15,633 : ERROR : SwingWorker-pool-5-thread-1 : : FileUtil : Google Authentication : 2:4 : Temp folder “C:\Users\t897420\AppData\Local\Temp\knime_test64275” does not exist (associated with node context “Google Authentication 2:4 (IDLE)”) - using fallback temp folder (“C:\Users\t897420\AppData\Local\Temp”
2020-04-03 14:42:09,978 : WARN : main : : Node : Google Authentication : 2:4 : Please authenticate using the node dialog.