Google Custom Search and Websearch node

Hi everybody, I am trying to make a search using the "Google Custom Seach" Search engine using the Wersearch node, but it gives me this error:

"Execute failed: Could not instantiate ws.palladian.retrieval.search.web.GoogleCustomSearcher, exception from constructor: searchEngineIdentifier must not be empty"

I already got my Google Custom Search Key API and introduced in the Preferences/Knime/Palladian Web Searcher/...., but I got this error. 

I am attaching the workflow 

Cheers

 

Knime Version: 2.11.2

 

 

Besides the API key, you need to specify the Search Engine ID (field below the API key in the preferences). You can obtain it from your Google Custom Search settings (or you need to create a Custom Search engine first). See attached screenshot.

Best,
Philipp

Thank you Philipp I added the ID, but this time I get this error:

"ERROR     WebSearcher                        Execute failed: ("NullPointerException"): null"

I am attaching the images just in case. 

Cheers

 

 

 

 

Hi there,

apologies, the error handling is currently sub-optimal, which makes it a bit hard to debug this issue. I have just made some improvements to the nodes, which will us give more meaningful error output. Could you please update the Palladian nodes which will be available by tomorrow on the update site, re-run the workflow and check for the error message?

Best,
Philipp

Sure of course thank you very much

 

Hi Philipp, I updated Knime in File/Install Knime Extensions and also in Update Knime, but I keep having the same error. I am pretty sure that besides the "Google Custom Search API key" and "Google Custom Search identifier" , there is something missing. 

 

I am attching a screenshot. 

 

Thank you

 

Hi mauuuuu5,

sorry about the delay. An new version of the Palladian nodes is available now. Can you please update your KMIME installation to the current nodes (version 1.5.0.201503092151), restart KNIME, re-run the workflow and post the results here?

Best regards,
Philipp

Hi Philipp, thank you for your help. I updated the nodes but I am still having the same error. 

Best regards

 

 

 

 

Hi there,

can you please turn on debug-logging (Prefs > KNIME > KNIME GUI > Console View Log Level (x) DEBUG) and restart KNIME. On the top, the console output should print you the Palladian build. Can you please post this information here?

Then please re-run your workflow and also post the console output.

Thanks,
Philipp

Hi Philipp thank you very much I did what you told me: 

The Palladian build: 

INFO      PalladianPluginActivator           Palladian version 0.5.0-SNAPSHOT (build 2015-03-06 11:18:31)

And I am attaching the image of the console output

Thank you 

mauuuuu5

 

 

 

 

Hi mauuuuu5,

thank you for the detailed report. I tried re-running your workflow and it works for me without problems. One question: Are you using Google Custom Seach the search the whole Web or have you limited your search to a smaller domain?

Thanks for your patience,
qqilihq

Hi Philipp, thank your for your help I was my mistake, basically the configuration of Google Custom Search did not allow to retrieve any search result. 

Thanks for your patience 

mauuuuu5

Hi there,

glad to know, thanks for getting back!

Best,
Philipp