Google Sheets updater Node: dates written as strings

Previous like thread: Sheets Updater saves value as strings (from 2018). I hoping there has been an update or another Node that is the solution.
New to KNIME, don’t understand the “solution” and can’t get it to work for me for the other thread. Am I to understand KNIME requires 5 nodes to just to write the correct format to a google sheets?

I’m trying to do some automated analytics around dates… don’t work with strings

Problem: Google Sheets updater is writing to sheets with a prefixed ’ to dates making them a string
ex: '2023/04/13

I do not see within the node RAW or USER_ENTERED which the other workflow solution refers to.

Hello @wadejohnson and welcome to the forum!

There is no need to use 5 new nodes. To replicate the solution from the other topic you can create a flow variable (with the variable name writeRaw and the value false) with the Variable Creator – KNIME Community Hub node and pass that flow variable to your Google Sheets node.
The configuration of the Variable Creator node would look like this:

Then you need to connect the output with your Google Sheets node and configure it to use the flow variable:

That way the flow variable overwrites the default setting.

Hope that helps.

Best regards


I have a few differences that may be confusing me

I’m using the Google Sheets Updater, not writer (don’t know if this is an issue)

I do not see the Job Manager Selection tab in my Variable Creator Node: I assume this doesn’t matter since your solution didn’t have any config on this tab anyways.

On the Flow Variables tab, I see less than what you display. There is no WriteRaw setting.

and the only thing in the drop downs of every one of these is knime.workspace.

You only see the knime.workspace flow variable because you did not execute the Variable Creator node yet. Once that node is executed the flow variables will be available.
However, it is strange that your Google Sheets Updater node only displays those 4 variables. What version of the KNIME Analytics Platform are you using?

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.