Guided Labeling for Document Classification

In the stage 4 of this workflow, “Download of the Labeled Dataset”, I have tried to download the model and labeled data set, but unfortunately I could not download neither of these. I have tried my own input and default data (movie reviews), but it does not want to download anyway. What could be a problem here?
Thank you very much in advance!

Hi @ac2089 and sorry for not answering sooner.
I must have missed this.

Did you solve your issue with the download buttons?
It works on my end. What happens when you download the data?
Can you send a screenshot of the WebPortal interface?

Let me know I will answer this asap.


Hi @paolotamag, thank you for sharing this awesome workflow! I am trying to run it in KNIME 4.4 and use step loop execution per the blog article. Unfortunately at Label Iteration #2 it no longer responds to ‘Close and Apply As New Default’. Is there some way around this so I can train the model in KNIME desktop and not KNIME Server?

I really appreciate any advice/guidance and thanks again for the workflow!

Hi @TardisPilot, unfortunately no. Sorry about that. I talked with the developers at the time. They told me the reason why you can’t apply view settings after the first iteration it is not some reason for forcing people to buy KNIME Server. It is rather about how the loop logic in knime works. That is: no node configuration can change after the first iteration. The nodes input and output can be inspected iteration by iteration, but no settings can be changed and that also counts for the interactive views. It’s like if KNIME is freezing the workflow segment within the loop in order to iterate data through it :frowning:

On KNIME Server this is somehow different given that the KNIME WebPortal next buttons are not exactly what the “Apply&Close” button do.

Did you check this new node?

We just released it less than a month ago. The whole Guided Labeling framework should be updated with this new button as it would then also work locally. I would need to investigate whether the recursive looping would still be an issue then.

To understand how the button works look at the video here: