Handling sd-file with External Tool node

Hi KNIME team,

an earlier post (http://tech.knime.org/node/20568) says that the data when using the external tool node is exported in quotes (" ").

This unfortunately also applies to sd-files (with csv-files once can understand :-). For sd-file this is not the standard format as so I would simply not quote chemical structure data (same way as when using sd-writer).

However, as written in above earlier post one can overcome by removing the quotes in the external tool / script. This as such is no issue, but the file (Output Data file) which should be read back generates an error - both for quoted and also non-quoted sd-files. Even a copy-paste of the exported sd-file is not re-imported and results in:

ERROR External Tool Execute failed: New line in quoted string (or closing quote missing). In line 1.

So this node requires adaptations with regard to sd-files and thus I would recommend to export with no quotes in order to generate a standard sd-file which could also be used by other applications than scripts.

PS. Also when generating mol files I would not have them quoted. Always use the standard definition.

Thanks for considering and fixing.

Best regards,

Andreas

 

 

 

If you install "KNIME External Tool Support (Labs)" from the "KNIME Labs" category you will get an additional external tool node that supports SDF properly.

Great! This node works fine with sd-files and no need to tweak quotes :-)

Thanks,

Andreas

 

Dear Knime team,

I also try to use the External Tool (Labs) node to process a SD file and to calculate some numerical descriptors. The import of SDF data and the calculation works fine - the intermediate output file contains a table with the calculated data. However, afterwards these results are merged into the original SD file. Can this mixing be disabled? I only need the data table as final output.

Thank you and best regards

Christian

Yes, an SDF cell holds all the original data. Convert it to mol2, mol, smiles format first, and this Will stop this mixing.

i.e. convert to mol2 and then connect an SDF writer.

simon,

Thank you, Simon. I have tried to use mol2 format - with a similar result, i. e. mixed table. Finally, I used a "Column Filter" to delete all unwanted columns including compound structures and got the small numerical table that way.

Best regards

Christian