Having trouble with a particular Excel sheet

I’m getting the error below. This excel sheet worked before but I had to refresh now I’m having this issue. This is an xlsx format.

ERROR Excel Reader 4:92 Execute failed: For input string: “4294917295”

Hi @sroberts,

Thanks for contacting us!

Could you please clarify if the mentioned cell in the excel is different formatted than the other ones in this column? Kindly note that it can be the reason of this error.

Looking forward to you reply!

Best regards,


So I get this same error on two separate nodes that I’m using to read data from two different sheets within the same excel document.

If it helps at all, this excel document is one I created using PowerQuery.

Can you open it in excel. Last time in a similar topic, the excel was simply corrupt.


Excel works fine. Not sure what is happening here. Maybe I’ll just try to use a new file?

Hi @sroberts,

A new file is a good try, but please note that it looks like a column which is formatted as string, but one of it’s cells is formatted as integer/number.

You could try looking up the number that failed to parse and change it’s formatting manually.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.