Help with a Rule Engine

Hello im new to KNIME and im trying to edit a rule engine.

The first 2 lines are working fine but the 3 with the not condition isnt working.
Also when i replace the NOT with != or <> it isnt working.
Is there another solution for this condition?

  1. $Werk 1$ = “201” => “5,263”
  2. $Werk 1$ = “530” => “5,128”
  3. $Werk 1$ NOT (“530 OR 201”) => “5,714”

Thanks!!

hi @Aco_Krivo and welcome to KNIME,

it should then be the “default” value…

true => “5,714”

However, to answer your question:

$Werk 1$ NOT “530" AND $Werk 1$ NOT “201” => “5,714”

if your String in the columns Werk 1 is really “530 OR 201”, then you have to remove the brackets

$Werk 1$ NOT “530 OR 201” => “5,714”

Hope that helps, greetz, Tommy

2 Likes

Thanks for the quick respond Tommy ur a legend!

It woked with TRue => “5,714”

but when i try it with the NOT condition i get following message:

Invalid settings:
Line 4, col 9: Invalid logic connective: NOT

is there a way to fix this too?

1 Like

Hello there,

also this one should work:

NOT $Werk 1$ IN (530, 201) => “5,714”

Quotes are not needed around numbers.

Br,
Ivan

2 Likes

you’re right!
Thanks for getting back.
The “NOT” clause has to be at the beginning of the line:

NOT $Werk 1$ = “530" AND NOT $Werk 1$ = “201” => “5,714”

And @ipazin gave us the most elegant way :slight_smile:

3 Likes

Thank you both guys @tommy @ipazin!! Now i could finish the workflow and ist working fine!

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.