How do I change date type in loop workflow?

Hello everyone,
I have a problem now, One loop workflow is not working. Because “The column ‘Order Level’ can’t be converted to the configured data type ‘String’”. So how can figure out this problem? How do I change date type in loop workflow?
Thanks in advance.

image

Did you uncheck the enforce types option as stated in the error message?

Note that with 4.4 this error will be gone and you can always convert your columns to string

Best
Mark

Hi @Mark_Ortmann ,
How can I uncheck the enforce types option?And I only use 4.3.1V of KNIME, if Ionly use 4.3V how I figure out this problem?
Thanks in advance.

Hi @Banksy,
have you tried the ‘Allow variable collumn type’ setting in the loop end node? This should prohibit the error. But probably you need the ‘Column Auto Type Cast’ node afterwards to get the correct column type.

BR

1 Like

This Option should be available in the excel reader node’s’ transformation tab. Once you unchecked this box you’d need to follow @morpheus instructions.

Hope this solves your problem.

Best,
Mark

1 Like

@Mark_Ortmann Thanks for your help, I didn’t uncheck the enforce types, I don’t know before.

1 Like

Hi @morpheus ,
You are right, I checked ‘Allow variable collumn type’ setting in the loop end node.
Thank you remind.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.