How to change from default R in KNIME to own version of installed R?

Hi,

When i try to run R code it states that the packages are not installed (grid and ggplot)

I have gone to the KNIME preferences and tried to change the file location from the KNIME default to my own version of R and now R is not working at all!

There are 2 main preference options related to R and where KNIME utilises R.

R

R(labs)

Which one do i change and how to do i change it so that it KNIME uses my version of R? found on my C: drive? The R version i want to use is version 3.1.0

If someone could go through a step by step example with example file paths that would great as i am not sure what i am really doing!!

Thanks 

Danielle

Hi,

Update on this:

It appears Knime only supports R2.X versions.. based on the help files i have:

  1. Executed: 'install.packages("rJava")' in my R installation
  2. Point to the R home directory in KNIME under Preferences > KNIME > R (labs) - i assume this is where R is installed? C:\R-3.1.0?
  3. Add a system property to your knime.ini:
    -Djava.library.path=C:\...library\3.0\rJava\jri\x64
    <p>pointing to the jri.dll (make sure you point to x64 when using 64bit) - again this is not much information when you dont know what a knime.ini file is!!! i assume it is the file that can be read using node pad and has the following information in it:</p>
    </li>
    <li>
    <p>-startup<br />
    plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar<br />
    --launcher.library<br />
    plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.100.v20110502<br />
    Djava.library.path=C:\R-3.1.0\library\rJava\jri\x64 &lt;&lt;&lt;&lt;is this right??&gt;&gt;&gt;&gt;&gt;<br />
    -vmargs<br />
    -XX:MaxPermSize=256m<br />
    -server<br />
    -Dsun.java2d.d3d=false<br />
    -Dosgi.classloader.lock=classname<br />
    -XX:+UnlockDiagnosticVMOptions<br />
    -XX:+UnsyncloadClass<br />
    -Dknime.enable.fastload=true<br />
    -Xmx512m</p>
    </li>
    <li>Removed the feature org.knime.features.rengine.r2.feature.group from the installation Help &gt; About KNIME &gt; Installation Details</li>
    <li>Restarted KNIME</li>
    <li>And i still get an error...R cannot be intialized. Cannot load JRI native library</li>
    <li>Can someone please help/ show me where i am going wrong?</li>
    

Hi,

Make sure you install the 64-bit version of R.

My slightly earlier R version knime.ini entry is:

-Djava.library.path=C:\Program Files\R\R-3.0.3\library\rJava\jri\x64

which I think is the default install directory inder windows.

Cheers,

Steve.

 

 

 

Can you give an example of how to change from default R in KNIME to own version of installed R?