How to connect with PostgreSQL Connector using the SSL

Hi all,

I updated my connectors from the legacy to the new one and I got this error:

ERROR PostgreSQL Connector (legacy) 0:1234:0:1128 Execute failed: Could not create connection to database: FATAL: no pg_hba.conf entry for host “my-ip”, user “user”, database “db”, SSL off

In the older PostgreSQL connector, I was able to select the checkbox SSL and now I don´t know how to do it.

Hi there,

which KNIME version are you running? How did you update it cause the error seems to come from legacy PostgreSQL connector node and not the new one? The legacy one still has SSL checkbox.

In new database connector nodes custom JDBC parameters are defined on JDBC Parameters tab.

See here for more info.

Br,
Ivan

Hi wpaiva,
you have to specify these two parameters in the JDBC Parameter tab as shown below:

ssl=true
sslfactory=org.postgresql.ssl.NonValidatingFactory

Bye
Tobias

3 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.