how to disable quickform when deployed on the server?

Hi,

I am wondering about the folllowing:

In my local knime version I created a metanode via 2 quick forms holding the configuration for a client X.

image

Since this metanode will be used for multiple clients I would like to keep it in a metanode as such (since there are some other operations aswell)

Now I would like to deploy this to the server and schedule a run every period X.
However, on the server I got this pop-up (the quick form) which i already configured.

image

Is there a way to disable this feature?

I read on other post that I could arange it with global variables, or possible get the forms out of the metanode but that is not something i prefer.

Thanks in advance

Best,

Tom

Hi @tom_m

Iā€™am thinking of something like this .With the Extract System Properties node, You can identify whether the wf is running local or on the server (using Rule Engine=> bottom/top) and create a flow variable as input for an IF SWITCH node. On the one branch the logic for local environment, on the other the logic for the server.
gr. Hans

1 Like

Hi Tom,

Can you try and uncheck the change boxes before publishing it to the server? Let me know if that helps.

Thanks,
Zack

1 Like

Hi Zack,
Unfortunatly this doesnā€™t solve my problem as I used the uncheck button to configure my variables per client.

Best
Tom

Hi Hans,

Thank you for the suggestion and that would work in case of my different settings related to the machine .

However I need to adjust simple settings that I made available throughout a component , a sort configuration file.

Thanks for the suggestion

1 Like

Hi all,

My current work around is to add an table creator note and convert it to a flow variables afterwards.