how to force datetime fields from being converted to strings

I have a Knime workflow that produces a table with a few fields of type 'DateAndTimeCell'. These cells were created from a Unix timestamp with a Java snippet as follows:

out_ts = new Date(((long) c_epoch) * 1000);

This all works fine in the workflow editor, but when I go to the report designer, the type of these fields is changed to String. In the Report builder view, I then need to manually change the property of the field in the dataset back to Date.

The annoying thing is, that this setting keeps on getting reverted whenever I change anything in the workflow, even if the change is not related to the mentioned dataset. Whenever this happens, I need to change ALL bindings again to the correct type, not only in the dataset, but also in all the elements that use these fields.

What is the proper way of passing datetime fields to the report designer, so they get recognised as datetime, not as strings?

Tim

(Not answering the how to do this, sorry I do not know.)

Why do you do adjust the binding? I had similar problems, but as I remember it was easier (as a workaround) to create new computed fields and use them as date fields instead (so they were used in cubes as date aggregation). Computations did not require adjustments on -unrelated- changes in the KNIME workflow.

Cheers, gabor