How to get rid of workflow credentials prompt?

How do I delete workflow credentials from a workflow?

I have a workflow to which I have added workflow credentials.
I would like to remove the workflow credentials so that I don’t get the prompt every time I open the workflow.

Things I have already tried:

  • I clicked on “Remove” in the prompt and saved the workflow after that, but the prompt still appeard when I opened the workflow the next time.
  • I have also copied the nodes manually into another workflow. After saving the other workflow, closing and reopening it, that workflow also prompted for the workflow credentials. It seems like some of the nodes are “infected” with workflow credentials.

I’m using KNIME Analytics Platform 3.5.3

Hi there!

Follow this steps:

  • open workflow
  • right click on workflow from Explorer window and choose Workflow Credentials…
  • choose credential you want to remove and click Remove
  • click OK

After saving and reopening workflow there should be no prompt for workflow credentials.


1 Like

Hey Ivan, thanks for the response. I have tried that. If I click “Remove” and then “OK”, the workflow doesn’t open. It gives me the error message “java.util.NoSuchElementException”.

I have a credentials input in my workflow and the name of the variable is the name of the workflow credential that is queried at the start of the workflow. Does a credentials input always cause the prompt to appear upon opening a workflow in the client?

Hi Ben!

Just to understand what is happening here. You have only Credentials Input node or you have both the Credentials Input node and global workflow credentials defined from workflow menu? See picture for global workflow credentials.


Credentials from Credentials Input node do not cause a prompt if password is saved. Otherwise do. Global workflow credentials, I think, should always cause the prompt to appear. Better to check latter one to be sure.


1 Like

Thanks again for the help, Ivan.

That’s the strange thing. When I open the WF, I get the prompt for WF credentials: cred_on_open

I click OK or enter the user and password by clicking “Edit”. In both cases, the WF opens without problems. Then I click on the WF in the KNIME Explorer and select “Workflow Credentials…”. It then shows me that there are no workflow credentials:


Ok. The window which is prompted I would assume it is from Credentials Input node because you do not have global workflow credentials.
If you do not need these credentials delete the node. If you need it but do not wish to get prompted each time enter user name and password in it and check Save password in configuration.
If you need it and do not wish to save username and password then you will get prompted each time workflow is opened.

Hope this helps!



Hey Ivan,
that solved the problem. Now I don’t get the prompt upon opening the workflow anymore. Thanks a lot.

Have a great day


You too,

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.