How to load workflow with not enough Java heap space?

Hi,

I have a problem with loading workflow. It was prepared on the same machine, saved, closed. Then, when I've tried to load it again, I get an error:

java.lang.RuntimeException: java.lang.OutOfMemoryError: Java heap space

Is there any way to load workflow without increasing -Xmx (currently I've reached the limit of memory).

Filip

Hello,

The FAQ gives this hint:

How can I increase the Java Heap Space for KNIME?

In the KNIME installation directory there is a file called knime.ini (under linux it might be .knime.ini). Open the file, find the entry and change it to for example. You may also consider to change the option and increase it to or even, depending on your computer's main memory. Note, that you main memory must be at the very least the sum of both values. (See also the answer for rarely observed problems while increasing heap space under Windows). If you use the developer version you have to edit the run configuration: "Run -> "Open Run Dialog..." -> tab "Arguments" -> field VM arguments -> enter -Xmx1024M.

This should help you.

As a last resort, when I don't have free memory anymore, I remove data directly through the workflow directory in the workspace.

Nico1990, thanks for your answer, however I cannot increase Java Heap Space anymore (as I've reached the limit). I managed to load the workflow by deleting some nodes in the workflow directory (as you suggested).

 

Best wishes,

Filip