how to run workfow bypass knime.exe to run java batch

Hi All,

I created a workfolw and I build a dos script to run job with this command, my need is to include this  in a java batch schedulated.

if is possible called directly the  plugins  .jar with params to bypassing knime.exe and config.ini, more or less, call exatly jar and params without execute knime.exe but using java:

an example is to run this jar that is containing in config.ini near the knime.exe:

java -jar org.eclipse.equinox.simpleconfigurator_1.0.200.v20110815-1438.jar

how to union this commands:

..\libs\KNIME\knime.exe -noexit -consoleLog  -application org.knime.product.KNIME_BATCH_APPLICATION  -nosplash -workflowFile=C:\project.zip

 

Thanks in advanced

No, this is not possible. You need to start the batch executor because otherwise the whole plug-in concept does not work. What is wrong with using the knime executable?

Nothing :-), knime executable run finely. Used executable is out of our enterprise standards for this type of job, my masterpiece ask my to find a solution to by pass .exe execution. I try to find anotherways, I negotiate it with him. 

Thank you very much Thor

 

Hm. Afaik the executable searches for a JVM at various places and then essentially fires up Java with something like "java <vmargs from knime.ini> -jar plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar <application arguments>". You may give it a try.

ok, I delete the knime executable and  I  launch this command with dos, it opens the window for the choice of workspace, but I miss the exact parameter to pass the zip file workflow:

java -jar org.eclipse.equinox.launcher_1.2.0.v20110502.jar -vmargs -XX:MaxPermSize=256m -server -Dsun.java2d.d3d=false -Dosgi.classloader.lock=classname -XX:+UnlockDiagnosticVMOptions -XX:+UnsyncloadClass -Dknime.enable.fastload=true -Xmx512m

I just have to find the equivalent parameter to load the workfolow directly with the jar, for example, the corrispective of this:

org.knime.product.KNIME_BATCH_APPLICATION  -workflowFile=C:\project.zip

Thanks
 

 

 

 

 

 

The command should look like this:

java -XX:MaxPermSize=256m -server -Dsun.java2d.d3d=false -Dosgi.classloader.lock=classname -XX:+UnlockDiagnosticVMOptions -XX:+UnsyncloadClass -Dknime.enable.fastload=true -Xmx512m -jar org.eclipse.equinox.launcher_1.2.0.v20110502.jar -application org.knime.product.KNIME_BATCH_APPLICATION  -workflowFile=C:\project.zip

The -vmargs in the knime.ini is only used by the exe in order to distinguish the application arguments (after the Jar file in the java call) and the vm arguments (before the jar argument).