How to set temp directory for batch execution mode

I need to change the Temp directory that Knime uses when excuting from the batch mode.

I have gone into the GUI and changed the Temp directory under Preferences > Knime; however when I execute a workflow from the batch commands it does not use that temp directory and continues to use /tmp.

I made sure I was in the same workspace when I changed it in the GUI as the same workspace that I am executing from the batch command.




Maybe try providing the preferences file in the batch command you use? Do you specify a workspace or just a workflow (I thought it was the later). 



Sorry, not sure what you mean by providing the preferences file in the batch command.  I specified a workflow in my batch command.






So where do you export the preferences file when in the Desktop software?


EDIT *****

Sorry - I found the export preferences under File.


Is there a default preference file that gets read if no file is supplied when running in batch mode?