HTTP Retriever no Result


#1

Hello community,

I have problems to get results form the following hompage:

https://www.gummi-plast.de/de/profile/auflageprofile

If I retrieve this website, I get this Warning:

WARN  HttpRetriever        2:19       Error retrieving https://www.gummi-plast.de/de/profile/auflageprofile: Exception javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated for URL "https://www.gummi-plast.de/de/profile/auflageprofile": peer not authenticated

I tried to check  "Accept all SSL certificats", but it didn't work either.

 

Thanks,

Cornelius


#2

Any ideas?
 


#3

Any ideas?


#4

The problem is likely the server which uses a wrong or expired SSL certificate.


#5

The "Accept all SSL certificates" option works for most cases, but there are unfortunately some, where it still fails (we already have a large ticket in our issue tracker of cases, where it fails :) ).

Debugging these issues and building workarounds such as the "Accept all SSL certificates" is unfortunately very time consuming, and as the Palladian nodes are a non-profit community project, my temporal priorities are on different ventures currently.

If it's important to you, I can offer two options: (1) I can give you access to the Palladian repo and you can build and contribute a bugfix yourself, (2) we're open to sponsored development, where we develop the feature for you.

Let me know in case that's interesting.

Best,
Philipp


#6

Hello Phillip,

I think I’m having the same issue from the below URL:

https://webb-site.com/dbpub/alltotrets.asp

After TableCreater(Node) in HTTPRetriever(Node) I am not getting any result. In Result column i am getting “?”.

Please can you tell me, is there way to resolve this or any other guidance.

Regards,
AbdulRehman


#7

https://webb-site.com/dbpub/alltotrets.asp

This URL works fine for me (HttpRetriever, current KNIME, current Palladian, no further config. necessary)


#8

Yes! It’s working in current KNIME version.
Thank You so much!!


#9

Great to hear, thanks for letting me know!