HttpRetriever node won't work!

Hi everyone!

I created a workflow that extracts information from several sites such as this one. The URLs used to begin with ‘http’ (no s) but now they won’t load unless you use ‘https’. Since this changed, my workflow stopped working.

As you can see in the image attached KNIME|690x370, the HttpRetriever obstains no results, so the rest of the nodes won’t work either.

Does anybody have any suggestions? Thank you so much! And for reference, I’m using KNIME 3.6 on Windows 10.

1 Like

I haven’t investigated this in detail for your case, but this is most likely caused by the fact, that Java does not have the appropriate root certificate for the certificate used by the corresponding site. You can circumvent this issue by ticking the following option:


Dear qqilihq,

Thank you for your kind answer. However, the Windows version doesn’t have the option you mentioned (KNIME|690x371) and I do not have a Mac at work. Dang. Is there anything else you can think of?

Thank you!


That’s actually independent from the OS – but you’ll need to make sure that you’re running a halfway recent version of the Palladian nodes. We added it not toooo long ago to the stable release.

qqilihq, I just realized I’ve been using the HttpRetriever (deprecated) node, not the HttpRetriever you used. I ticked the option you mentioned and it worked like a charm!

Thank you so, so much. Have a nice day :slight_smile: