HttpRetriever: Timeout preference?

I often see issues with slow loading pages being missed by the HttpRetriever node as they time out too quickly but if I catch empty results cells with a Java snippet row filter then retry, I get the page on a second attempt.

Any chance you could add a section in the knime preferences or in the node configure dialogue for the HttpRetriever node that specifies the 'timeout' value?

Hi James,

I have added configuration options to set timeouts and retries, it will take approx. two/three weeks though, until it is in the stable version, as I still need to fix some issues with the new nodes and the HtmlParsing and I'm on holiday now.

Will let you know, when it's available.

Philipp