I need help regarding deep learning environment setting

Hello, I hope everybody is doing great.
I am a beginner with KNIME and trying to use the KNIME Deep learning. I have tried to run a simple workflow downloaded from the KNIME hub but it fails repeatedly after reaching 99%. At 99% it stays for a long time. I have tried a lot to check the environment and follow the link but I could not understand.

I really need quick help as I am running out of time for the task I am doing.
Looking forward for help.

Hi @Faheeemahmed -

Can you please post the relevant portion of the error log? Unfortunately a screenshot is not sufficient to diagnose the problem.

1 Like

Hi @ScottF, thank you for your prompt response.
I have attached the images for KNIME Console, KNIME Error log along with Keras Error Log
Please have a look and help me solve this problem.
Looking forward to hearing from you.

Knime Log.txt (9.0 KB)

It’s not clear to me from the logs what might be wrong, but I am far from a Python expert. A couple of questions for you:

  1. Did you set up the Python environment KNIME is using by following our documentation (KNIME Deep Learning Integration Installation Guide), or did you set it up independently?

  2. Does this similar workflow execute on your machine, or does it cause the same problem? KNIME Deep Learning - Train MNIST classifier with Keras nodes – KNIME Hub

Hi @ScottF

  1. Yes I have followed your documentation for the deep learning environment setting. The picture for the set deep learning environment and python are shown in the picture below.

  2. I have run the workflow you sent with some changes but it is given the same problem as before. I have attached the picture and corresponding log information is also attached below. Honestly, I am very tensed because, I have tried many ways to solve this problem but unable to do it until now. Please help me.

    KNIME Log _ 1.txt (18.3 KB)

Looking forward to hearing form you again. Thank You @ScottF

@Faheeemahmed maybe you could take a look at this thread to see if the Conda environment propagation could help:

1 Like

I asked internally about this, and got a couple of responses - unfortunately, nothing definitive. But maybe it helps:

"Hm, doesn’t seem to be a KNIME-related problem. I found a couple of GitHub issues that suggest that some other process tries to use the GPU at the the same time. That’s something I’d check (e.g. using the nvidia-smi tool). "

“I am pretty sure it is not KNIME related but has something to do with the users CUDA, Nvidia driver, etc. installation. Here is a stackoverflow thread. The “solutions” seem rather random.
python - TensorFlow: Blas GEMM launch failed - Stack Overflow

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.