Ilastik output file does not exist error

If the error message always says the file does not exist and the path contains a slash and it works on Mac where slash is the standard folder separator. Is it possible that somewhere in ilastik the path separator has not been adapted to the OS environment?

Question is would this happen on all windows installations or could it help to get a fresh version of KNIME and ilastik?

Do we have a minimal example workflow and someone with a Windows installation ready could test?

/ Vs \

@ukitel and @mlauber71 thanks for your input. Sorry for the late response, I was travelling.

I created a new workflow (created from scratch on a PC with czi images) and it worked regardless of the memory allocated to ilastik in the configuration panel. However, for the workflow shared by my colleague (created on a mac with a table created form czi images which works on the mac) and my old workflow (created on a PC -using the same nodes as the new one- with a tiff exported form a czi through QuPath and ImageJ, uploaded on message above on Mar 28) I still get the same error even when matching the memory allocated to ilastik in the configuration panel to that available on the task manager.

@mlauber71 The reason why it doesn’t work on the workflow created on the mac could be a path error not adapted to the OS environment, but I don’t know where to check/correct the path for the temporary files for knime/ilastik communications. The correct path for the temp file is D:\Users\zeiss\AppData\Local\Temp\ilastik not D:\Users\zeiss\AppData\Local\Temp/ilastik/f2c09662-e01d-43de-b5a5-feac0c17a63c/file0_result.tiff as stated in the error.

For the old workflow, I don’t know… It’s ok for now, I was able to solve that image cohort using another segmentation and I can work on my current cohort with ilastik, but the issue has not been fully resolved.

FYI @gab1one @christian.dietz @stelfrich

Thanks,

Paula

Hi @paulage,

There was an issue with the serialization of images in KNIME Image Processing that had to be fixed with one of the recent versions. This leads to issues with workflows in an executed state that have been built with versions prior to this fix – sorry for the hassle!

It’s great that this has worked for you, @ukitel! The more generic issue seems to be that processing failures (which can be caused by a multitude of reasons) leads to the expected outputs not being available…

Since ilastik is run in a dedicated process it does not share the heap with KNIME. That’s what the CPU and memory settings in the configuration dialog are supposed to handle…

I have opened https://github.com/knime-ip/knip-ilastik/issues/24 to keep track of this issue.

Best,
Stefan

1 Like