image size not found or kernel size not found error!


I have tried a workflow using DL4J that creates a simple MLP model.

But, I get an error that "the kernel size not found" or "image size not found"

Thanks in advance for any help on that problem


Hi Kemal,

can you upload your workflow such that I can reproduce this issue for further investigation?


Hi Marten, Thank you for your interesting. 

I uploaded the workflow. 

Best regards...


It seems that the screen shot (error-2.png) is the essence of the mistake. 

Thanks for your time and effort. 

Hi Kemal,

which version of KNIME are you using? Unfortunately, I cannot reproduce the error. I just downloaded a KNIME 3.4.2, and opened your workflow. There is no 'image size' error showing neither if I open the dialog and hit apply nor if I directly execute the node. The Learner shows the 'Label column not available or not yet selected for SUPERVISED training. Domain of Label column may not be available.' warning, however this will go away after you executed upstream nodes or selected a valid label column.

Are you maybe using an older KNIME version? Could you describe the steps which you did that resulted in the error showing?



Hi David, 

I just tried both KNIME 3.4.2 and KNIME 3.4.1 versions on bupa dataset.

is the problem causing because of dataset?

which dataset you have used in your testing?

Would you share your dataset with me! Because, I am facing problems with my datasets. 



I used the workflow you attached earlier ( dl4j_save_read.knwf ). I did no modifications to the workflow. Does the problem occur on that workflow for you?  Which operating system are you using?

Hi David, thank you for your interesting. 

Operation system: Win 10 64 bit. 


You attached a workflow earlier. Does the problem occur on that workflow for you?

Hi David, 


"ımage_sıze not found" 

"kernel_size not found" errors are seen in dialog windows fo DL4J Learner node. 

As I stated earlier, I could not reproduce the error on this workflow. I could import the workflow and open & close the Learner dialog without any problems. Could you maybe explain step by step what leads to the error showing in your case? Specifically, do you directly open the dialog of the Learner node after you opened the workflow? And then, do you change any configuration or do you directly hit the OK or Apply button.

Hi David, 

I could produced the workflow on Debian / Linux. But, i couldn't produced on win 10. The problem is Win 10. 

Thank you for your interesting. 

Best regards...

Please have a look at my previous post and try to explain the steps which lead to the error.

I can't help you otherwise, because I can't reproduce the error myself.

I’m getting same error while trying to apply configuration of DL4J Feedforward Learner node for both classification and regression. Could this error be related to OS’s language? We do probably use same OS language with OP and error message returns this as “ımage_sıze” which contains turkish letters.

It’s a bug in our code due to Turkish locale. This will be fixed in the next bugfix release.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.