ImageReader nodes throw RuntimeException when I try to configure them - HELP!

 

Hello,

 

I am trying to get to grips with KNIME at the moment. My intent is to evaluate KNIME's existing capabilities and potential as a image analysis tool.

After installing KNIME yesterday I have followed the basic tutorial steps and enjoyed very much what I saw.

I have then installed the Community Nodes and tried to do some basic image analysis. (Loaded some tiffs and fed them into a gaussian convolution… worked all very nicely!)

 

Today I tried to continue my expedition, but I am not able any longer to use the Image Reader node.

Every single time I try to configure one I get the following console output:

ERROR NodeContainerEditPart The dialog pane for node 'Image Reader 0:1' has thrown a 'RuntimeException'. That is most likely an implementation error.

 

To my memory the only thing I made since it worked the last time and now is, that I have modified my test workflow, played with a ton of existing nodes, etc.

This morning I started by downloading and importing the ImageJExampleWorkflow which contains an ImageReader. There I experienced the problem the first time, but now also the workflows that worked fine yesterday show the exact same error.

 

I then thought I might have some buggy version (although having installed the release versions) and installed the nightly builds of everything. The problem is unchanged. Even if I create a completely new workflow, only add an ImageReader, I an not go on 'configure' in order to select some images (the dialog would never show up).

 

Please help,

Florian

Hi Florian,

thank you for reporting this bug. Could you tell me your Version of your MacOS? I'm asking because there is a Java implementation problem on Mac OS X  10.7.4 with a component called JFileChooser Panel (which we are using in the Image Reader). Here is a post of mine from some weeks ago:

I just googled the error message which came up in the log and this seems to be a MAC Java problem. There has already been bug filed at apple.
One solution to avoid the crashed would be to update to Mountain Lion (10.8).
See:
http://forum.processing.org/topic/java-errors
or
https://discussions.apple.com/thread/3948246?start=0&tstart=0
 

We are working on a solution for this.

If all this error description doesn't fit to your problem, could you then please post your configuration (KNIME version, MacOS Version etc)? Then we will try help you out as soon as possible.

Cheers and thanks for your post!

Christian

 

Hi Christian,

thanks for your quick reply.

I am using OSX 10.7.5, and have currently istalled all the latest updates.
My KNIME is 2.6.3, downloaded and installed just yesterday (29.10.2012).

What confuses me a bit is that I have actually used the ImageReader node yesterday night to load and play 10 tiff files. Is there an alternative way to load tiff images that I might have used and forgot about it? Am I being confused here???

No seriously, I am sure I have clicked on configure and I got a dialog presented that I could use to load a couple of images which I then fed into the gauss convolution node...

Ok, thaks for our help,

Florian

PS: Updating to 10.8 is unfortunately ot an option at the moment... I am sitting on a machine that is given to me from the Max Planck Institute, and they do decide for me in this case... ;)

Hi Florian, just a minor update: I just installed Mac OS 10.7.4 and could reproduce the error. It somehow appears unfrequently ... I will have a look at it right now :)

Major Update:

I fixed the bug on this maschine here and it seems to work. Actually this is a dirty workaround, but since now this has no side-effects.

I would be very thankful if you could test it on your maschine: Therefor simply update KNIME Image Processing (available in 30minutes) from the current nightly build update-site:

http://tech.knime.org/update/community-contributions/nightly

Hopefully this works for you, if not.. let me know and I will go on fixing :)

Greetings!

Christian

 

 

Hi Christian,

wow, cool, thanks for your fast help.

I hope I do not make a fool out of myself now, but I can not reinstall (update) KNIME Image Processing. The updater does not find anything, and if I use the 'Install New Software...' menu item only tells me 'All items are installed'.

 

Should I be able by now to update, or is the availability a bit belated?

 

Thanks again for your precious help,

Florian

Hi Florian,

no problem!

You need to click on Help -> Install New Software -> Add...

and there you add http://tech.knime.org/update/community-contributions/nightly this update-site. then you should be able to update. I just started the build job for nightly build (just to be sure). this will be available in 20minutes from now. If it doesn't work with the nightly build update-site I need to double check it tomorrow.

I'm not 100% sure the fix will work for you, so if it doesn't I will go on with my investigations :)

Have a nice evening!

Christian

Yes, actually now I could update!

Thank you so much for your fast help. As far as I can see everything works perfect now! :)

 

Cheers,

Florian