Installation problems

I am trying to install the Indigo nodes but it gives me this error, same for RDkit and Earl Wood??

Any suggestion?

 

Cannot complete the install because one or more required items could not be found.
  Software being installed: Indigo KNIME integration 1.0.0.0000965 (com.ggasoftware.indigo.knime.feature.feature.group 1.0.0.0000965)
  Missing requirement: Indigo extensions for KNIME Workbench 1.0.0.0000965 (com.ggasoftware.indigo.knime.plugin 1.0.0.0000965) requires 'bundle org.knime.workbench.core [2.4.0,3.0.0)' but it could not be found
  Cannot satisfy dependency:
    From: Indigo KNIME integration 1.0.0.0000965 (com.ggasoftware.indigo.knime.feature.feature.group 1.0.0.0000965)
    To: com.ggasoftware.indigo.knime.plugin [1.0.0.0000965]

I am using Ubuntu 11.04 and Knime 2.3.0

Seems as if there is a dependency of the indigo nodes to KNIME v2.4:

... requires 'bundle org.knime.workbench.core [2.4.0,3.0.0)' but it could not be found

I am trying to update to v2.4 but it tells me: update is not permitted?

Maybe you are not the installation user? Is it a central installation not maintained by you but some admin?

I have administrative privileges so it should be fine, I am running it on the computer where it is installed.