Integers read automatically as date after 2nd try

I’m a newbie, I literally just learned about Knime in a training today.

On my first workflow, I utilized a database extract (extracted 7PM) and exported it to excel to serve as my starting raw file in Knime. It has a due date column where it displays integers i.e. “44530” and read as integers in KNime in which I used Date/Time Shift (Legacy) to transform into specified formatted date. Workflow = OK.

Then, I utilized another extract (extracted 10PM) to run through my first workflow to see if it can be consistent in running similar files. Basically, I just used the more updated raw extract from a certain database but I can no longer run the Date/Time Shift (Legacy) since it’s error / cannot execute because the due date column at the onset can now be read automatically (without use of nodes) as formatted dates, not as integers. Error should be related to the Date/Time Shift since it can no longer ready any integer columns (no shift value).

I didn’t even make any manipulation in the raw file but why is that? I appreciate any helpful comments. Thank you.

1 Like

Hi @iloveaknime and welcome to the Knime Community.

Can you please share your workflow so we can see what you are doing, and we can then point you to the right direction?

Also, is there any reason why you are using Legacy nodes? Legacy nodes are nodes that were used in older versions and have been replaced by better alternatives (either by newer versions of the nodes, or replaced by alternate nodes), and are in the processed of being deprecated / phased out. They usually exist for the current release only to give time for migrating to the newer nodes. So you would find Legacy nodes in old workflows and you would not use the Legacy nodes when creating new workflows.

2 Likes

Thanks for letting me know, I opted to utilize the latest extract and retested another latest extract today to check if the dates are readable at the onset moving forward and it worked. I don’t know how but I was just able to change my date preferences in KNIME


settings. Also, noted on your advice, I deleted legacy accounts and proceeded as usual.

2 Likes

Hello @iloveaknime,

and welcome to KNIME Community!

If I got it right you managed to figure it out or at least it’s working now. To force Excel Reader to read certain columns always same (as integer for example) you can use Transformation tab and specify it there. However would like to point out you can use KNIME node to directly connect to your database and thus avoid need to extract data into Excel to import it into KNIME. Check out here for more information:
https://docs.knime.com/latest/db_extension_guide/index.html#intro

Br,
Ivan

2 Likes