Is it possible to remove the space between elements in composite views?

Just wondering if it is possible to remove the space between two elements in a component’s composite view. I can increase the space by tweaking the margin sizes either in the css class of the containers or in the Advanced Composite View Layout, but I can’t seem to make them smaller than the default. Setting the margin size to 0 still leaves a space, and setting it to a negative number does not lead to a pretty result.

I realise that this is probably a rare use-case. I have a stylish header that is generated by javascript, and I want to add some additional text to it. Rather than modify the javascript (which I don’t know much about), I figured I might define the additional text in a separate Text Widget and join it to the header. But this will only work if there is no gap between the two elements.

Is this not possible, or have I just not tried the right setting?

Hallo @AngusVeitch1,

this seems to be a bug. I think it was possible before to completely remove the space between two elements in the composite view. I created a ticket for it to be fixed (internal reference: WEBP-805).
I will let you know as soon as there are any updates. Sorry for the inconvenience.

Kind regards,


Thanks @janina, I’ll look forward to any updates!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.