issue : Spark Context Livy not working

I am trying to use Spark Context with Livy.
I have tested livy locally successfully with curl and ran livy tests.
But i cannot Execute Spark Context Livy in KNIME,
the execute button is greyed out and never becomes green
regardless of how much I change the configuration.

I also tried Spark context jobserver with the spark-jobserver running in docker
but face other issue with timeout on akka.pattern.AskTimeoutException: Ask timed out on [Actor[akka.tc…

livy seems much easier to deal with
but I cannot figure out a way to make it green executable in KNIME.

btw I am using KNIME 3.7 latest version

I tried on mac and linux , same issue:

error is :slight_smile: Excluding compile: javax.swing.text.GlyphView::getBreakSpot

Exception in thread “AWT-EventQueue-0” java.lang.IllegalStateException: No node context registered with the current thread

at org.knime.core.node.workflow.NodeContext.removeLastContext(NodeContext.java:169)

at org.knime.workbench.ui.wrapper.WrappedNodeDialog.removeNodeContext(WrappedNodeDialog.java:746)

at org.knime.workbench.ui.wrapper.WrappedNodeDialog.lambda$4(WrappedNodeDialog.java:186)

at org.knime.core.node.util.ViewUtils$2.run(ViewUtils.java:155)

at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)

at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)

at java.awt.EventQueue.access$500(EventQueue.java:97)

at java.awt.EventQueue$3.run(EventQueue.java:709)

at java.awt.EventQueue$3.run(EventQueue.java:703)

at java.security.AccessController.doPrivileged(Native Method)

at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)

at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)

at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)

at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)

at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)

at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)

at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Hi @lefromage,
which RemoteFileSystem Connection do you use with the Livy Context node?
For S3 or Azure BlobStore you need to set a staging area, maybe you missed that?

best regards Mareike

1 Like