Issue Value Selection limit

Dear all,

 

I use KNIME 2.11.2 on CentOs and I have an issue with two nodes (Value Selection QuickForm and Value Selection (Labs)).

 

I have to deal with a big input table (more than 1.000 entries) and I would like to use the value selection to sort it depending on the context.

 

First, the Value Selection QuickForm just return "Data does not contain any column with domain values." and if I use a Row Filter (60 first rows) before it seems to be fine.

 

Second, the Value Selection (Labs) return the same answer, if I use a Row filter (60 first rows) before I can select from my String column a value BUT I can't select any Integer or Double value...

 

If someone could explain this limit or give me a new hint, I would be most grateful.

 

Sincerely yours,

Chappie.

Hi Chappie, 

This has to do with the meta information we carry around for each column that we refer to as the "table domain".  By default in KNIME we only retain domain information for string columns if there are fewer than 60 unique values.  We do this because we store this information in memory.  To fix the problem, simply add a domain calculator node and set it to not restrict the number of possible values.  There is a checkbox for this on the bottom right hand side. Give it a try and let us know how it goes. 

  

1 Like

Dear Aaron,

This method is perfect! For everyone that need such a thing you can:

- Select every column (String, Integer, Double). Just keep in mind that for Integer and Double you have to use the Value Selection (Labs) !

- There is no limit (I can reach more than 10.000 entries) !

Many thanks for your time and interest.

Chappie.

I was having issues reading multiple files due to the number that was in the directory.  This solved the issue!  Thank you so much for alleviating further frustration on my part!

Scott

Thanks a lot, it worked for me as well!