Issue with BigInt

I’m using a Knime process to prepare some monthly data for importing into Tableau. Basically, it’s a few xls readers bringing in some monthly reports, followed by some column renames, string manipulations, rule engines, and concatenates, then a joiner followed by a concatenate with the previous month file (to stack the data and create a YTD). I then use xls writers to create the file to bring into Tableau.

This process worked great until I added a string manipulation and rule engine to each report to pull the month out of a date string and convert it to three-letter month name (e.g. Jan, Feb). Now, my data won’t import into to Tableau due to the fact that the data is of the BigInt form. Any idea how i can solve this so my workflow is usable again?

Hi @nlain,

first of all sorry for the late response. I didn’t quite get where data of type BigInt comes from. In KNIME you only have numeric data of type int, double and long. Is it possible to share a workflow that reproduces this?

Additionally, have you tried the Tableau Integration already? If not, you should definitely give it a try: