Issue with Quick form Double Input node?


I am using a Double Input node in my workflow and I'm getting a funny behavior when I run it from our Knime Web portal.  If enter 0,56 it is changed into 56.0; if I enter 5,2 it is changed into 52.0.  On my PC the decimal separator is the dot and not the coma.   When running the workflow from Knime (Quick form execution), it works fine.

Any idea what's going on?


In general the decimal seperator should always be the . (dot). KNIME does not take your computers locale settings into account to insure interoperability.


I have a similar problem. Running 3.3.1. In the config dialog of a Wrapped Metanode with a Double quick form input.

My decimal seperator IS the comma (German) and it is also interpreted as such in that form. 

1.500 stays 1.500 after pressing Apply. Resulting variable value: 1500.0

1,500 becomes 1,5 after pressing Apply. Resulting variable value: 1.5

But what bothers me even more, is that it does not allow me to specify values with more than three numbers after the seperator.

Using string + conversion now.

If this is already solved in 3.3.2 or later, please ignore.