Issue with redshift connectivity - Could not find the [connection] database driver

Hello all,

Hit a strange issue while configuring new KNIME server (4.12.4) instance (ubuntu/aws pre-configured instance). Everything setup and working correctly apart from the redshift cluster connectivity. What was done/checked so far:

  • supported version of the jdbc driver uploaded to the machine (redshift-jdbc42-2.1.0.1.jar), rwx permissions provided for all users (including knime) to the entire directory structure and the file itself (so it is not permission related)

  • preferences.epf configured accordingly:

  • This particular settings (url, driver version, driver/connection configuration) already tested and working on my local machine - so incompatibility excluded as possible reason

  • knime server (tomcat) restarted after configuration was applied (so not the reason either)

After all that, we are still getting error: “Error occurred while loading workflow into memory … Could not find the [redshift_con] database driver” when we try to run workflow on the server:
image

Any help would be greatly appreciated - are we missing something/step in the process / any clues on what could be the problem here?

Thank you VERY MUCH in advance!

Hello @gpamukov,

Server Setup when working with databases is described in Database Guide from KNIME Docs:
https://docs.knime.com/latest/db_extension_guide/index.html#server_setup

Although you can register JDBC drivers directly using customization seems easier/better.

Br,
Ivan

3 Likes

Thanks Ivan,

Just a small addition: the customization profile executor is the successor of the formerly used preferences.epf. Just copy your preferences.epf contents into <workflow_repository>/config/client-profiles/executor/executor.epf and make sure that the executor profile is configured to be used either in the knime.ini or the executor service. More information are accessible here.

Best,
Michael

3 Likes

Thank you very much - it is configured and working now!

Best Regards,
G. Pamukov

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.