Java heap space error on server

I’m receiving a Java heap space error when running a excel sheet appender on the knime server (my workflow cleans and analyses data on the server), is there any solution that I can use to solve this problem or how I can increase memory efficiency of nodes on the server?

At the moment I’m splitting the work into two different batches, this is not ideal so it is only a temporary solution.

Hi @tiaandp

How much memory you KNIME Executor is assigned to take and how much memory you machine has? You can adjust the amount of memory the executor can consume by change the knime.ini -xmx parameter to increase the amount of memory

1 Like

Thanks for your reply @ana_ved

Where can I change the above mentioned parameters on the server?

Hi @tiaandp , you need to have access to the Knime server and modify the knime.ini on the server.

The knime.ini is in the folder where Knime is installed. Open the knime.ini file, and look for the line that has -Xmx, that’s where the memory allocation is defined.

For example, -Xmx8192m means 8192mb (megabytes), which is essentially 8gb (gigabytes), which can also be written as -Xmx8g, and -Xmx32g for 32gb, etc

Then save the knime.ini file, and restart Knime for the changes to take effect.