JSON Reader: Timed-out

Is there a way to control the time-out period for the “JSON Reader”? I get an occasional console message like this:

ERROR JSON Reader 0:48:0:49:0:15 Execute failed: Can’t access ‘https://api.stlouisfed.org/fred/series?series_id=WILL5000INDFC&api_key=xxx&file_type=json’. (Read timed out)

I’m weak with KNIME (and rusty), but do remember using other nodes for API/REST related things, and one of them did have a time-out setting. I don’t see a time-out setting for “JSON Reader”, though… :frowning:

Hi,

I guess you have to use a “GET Request” node to get the JSON and then use a “JSON Path” to read the data (Or convert it to XML and then use a XPath node).
you can use the request in Get Request node which has a timeout setting as well.

Best,
Armin

Yes, with the addition of an Ungroup node, I think I am working again!