JVM not found error when opening other workflows

Hi Jon Fuller,

I seem to have encountered the same/similar problem as Depressed Andy.

I’m new to Knime. I’ve uninstalled and re-installed Knime a few times because of errors with Extensions (maybe uninstalling and reinstalling was my ultimate problem that I shouldn’t have done). I believe I may have plug-ins/.jar files in different folders in my laptop?
Anyhow, the error that I’m getting is the following. What’s strange is that I can open my own Knime workflows, as well as example workflows online, but I get the following error when trying to open a colleague’s workflow. image

Here are the details from my Knime.ini:

Thanks so much!


The path in the Knime.ini looks correct, but the one in the error message does not. Can you check your PATH variable (https://www.java.com/en/download/help/path.xml) if it contains the path specified in the message? Please also check if there is an environment variable called JRE_HOME.
Kind regards,

My apologies for my late reply. Thank you also for your help!

I followed the instructions in the link that you’ve provided. I updated the file path to my javaw.exe, and that seems to fix some things. However, I now get this error (attached photo). I try to update the path environment variable to find jvm.dll, following the same instructions in the link, but I keep getting the same error message.



have you tried reinstalling KNIME once more to get rid of this? In theory it should just work out-of-the box and I think any solution I may come up with will break other things.
Kind regards,

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.