K-AI cannnot login to hub

Hello. Is there a way how to fix error login failed to My-Knime-Hub when using K-AI? Error while retrieving server information for login, probably because the server is not reachable.
We don’t have admin rights in work for Windows 11 and I have updating Knime and installing extensions from local zip archives. I think it has something to do with it rules.
Thank you in advance.

1 Like

Hi @hadesian, could you please send us a screenshot of the error you’re getting, and perhaps a log if possible? This would help us understand your problem better.

Thanks!
Aline

Hi @alinebessa,

here you go, screenshot of error and message and log.
image
log.txt (4.3 KB)

Thank you.

Hi @hadesian,

The underlying error “PKIX path building failed” suggests that you are connecting to a web service that returns an untrusted certificate, which prevents KNIME from establishing a secure (https) connection to that service. This untrusted certificate probably comes from a company-internal website or a company proxy that replaces other websites’ SSL certificates. Assuming your company’s IT has preconfigured the needed certificate(s) on your computer, you can instruct KNIME to use the operating system’s certificates like so.

To this end, add these two lines at the end of the knime.ini file within the KNIME installation folder (while KNIME isn’t running):

-Djavax.net.ssl.trustStore=NONE
-Djavax.net.ssl.trustStoreType=WINDOWS-ROOT

Alternatively, or should the above not work, please remove the entries from the knime.ini again and proceed with any of these options:

  • Import the required SSL certificate(s), see this video: https://www.youtube.com/watch?v=FYD17GbNZsk
  • If you are receiving this error using our REST nodes (GET, POST, etc. Request): select “trust all certificates” (communication remains encrypted, but we won’t verify that the server is who they claim to be)
  • Use http instead of https (communication will be unencrypted)
  • Possibly change the proxy configuration you’re using (File > Preferences >General > Network Connections)

Alternatively, also check this Forum entry. Once the issue is solved, you probably won’t need to use update archives any more, and you’ll be able to share this knime.ini change among colleagues or with your IT department if they distribute KNIME centrally.

Please let us know if you have any issues with these approaches.

Cheers,
Aline

2 Likes

Hi @alinebessa,

adding two lines at the end of knimi.ini worked like a charm. I can now update, install extensions directly within system and K-AI is working! Thank you very much and have a nice day.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.