Keras in R

Hi,

I built ANN model in Keras (2 hiden layers of 32 nodes) in R learner. It evaluates perfectly in R Learner.

> print(knime.model)
Model
________________________________________________________________________________
Layer (type)                        Output Shape                    Param #     
================================================================================
dense_1 (Dense)                     (None, 32)                      1152        
________________________________________________________________________________
dropout_1 (Dropout)                 (None, 32)                      0           
________________________________________________________________________________
dense_2 (Dense)                     (None, 32)                      1056        
________________________________________________________________________________
dropout_2 (Dropout)                 (None, 32)                      0           
________________________________________________________________________________
dense_3 (Dense)                     (None, 1)                       33          
================================================================================
Total params: 2,241
Trainable params: 2,241
Non-trainable params: 0
__________________________

 

But when I pass it to R predictor, knime.model shows -

> print(knime.model)
<pointer: 0x0>

 

What can be possible issues?

 

PS- I have already posted on R forum of KNIME, but no one responded :(

Regards,

Nikhil

 

Please don't post duplicate questions in the forum.

Closing this one. https://www.knime.com/forum/r-statistics-nodes-and-integration/keras-in-r