Knime 2.10.0 crashes when attempting to configure R Snippet

Using Knime 2.10.0  I created a new workflow that uses the R Snippet on a linux machine..  As soon as a attempted to configure the R Snippet Knime crahed and the GUI disappeared.  The output that appeared after the crash and the tail of the knime.log are listed below.

Any suggestions to allow the use of the R Snippet?

Thanks, Doug

JVM terminated. Exit code=2
/home/username/knime_2.10.0/jre/bin/java
-XX:MaxPermSize=256m
-server
-Dsun.java2d.d3d=false
-Dosgi.classloader.lock=classname
-XX:+UnlockDiagnosticVMOptions
-XX:+UnsyncloadClass
-XX:-UseSplitVerifier
-Dknime.enable.fastload=true
-Xmx4G
-jar /home/username/knime_2.10.0//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /home/username/knime_2.10.0/knime
-name Knime
--launcher.library /home/username/knime_2.10.0//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505/eclipse_1407.so
-startup /home/username/knime_2.10.0//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
--launcher.overrideVmargs
-exitdata 5b2a80d8
-vm /home/username/knime_2.10.0/jre/bin/java
-vmargs
-XX:MaxPermSize=256m
-server
-Dsun.java2d.d3d=false
-Dosgi.classloader.lock=classname
-XX:+UnlockDiagnosticVMOptions
-XX:+UnsyncloadClass
-XX:-UseSplitVerifier
-Dknime.enable.fastload=true
-Xmx4G
-jar /home/username/knime_2.10.0//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar 

 

 

The tail of the .../workspace/.metadata/knime/knime.log shows:

2014-07-11 11:45:09,206 DEBUG AWT-EventQueue-0 RController :
 PATH:
/home/username/perl5/bin:
/hptc_cluster/lsf/8.0/linux2.6-glibc2.3-x86_64/etc:
/hptc_cluster/lsf/8.0/linux2.6-glibc2.3-x86_64/bin:
/home/username/perl5/bin:
/home/username/perl5/bin:
/apps/source/R-3.0.2-mkl/tools:
/apps/source/R-3.0.2-mkl/src:
/apps/source/R-3.0.2-mkl/share:
/apps/source/R-3.0.2-mkl/po:
/apps/source/R-3.0.2-mkl/modules:
/apps/source/R-3.0.2-mkl/m4:
/apps/source/R-3.0.2-mkl/etc:
/apps/source/R-3.0.2-mkl/bin/exec:
/apps/source/R-3.0.2-mkl/bin:
/apps/source/R-3.0.2-mkl:
/apps/source/intel_parallel_XE/composer_xe_2013_sp1.0.080/bin:
/apps/source/intel_parallel_XE/bin:
/source/intel_parallel_XE/composer_xe_2013_sp1.0.080/debugger/gui/intel64:
/source/intel_parallel_XE/composer_xe_2013_sp1.0.080/bin/intel64_mic:
/source/intel_parallel_XE/composer_xe_2013_sp1.0.080/debugger/gdb/intel64/py27/bin:
/source/intel_parallel_XE/composer_xe_2013_sp1.0.080/debugger/gdb/intel64_mic/py27/bin:
/source/intel_parallel_XE/composer_xe_2013_sp1.0.080/mpirt/bin/intel64:
/source/intel_parallel_XE/composer_xe_2013_sp1.0.080/bin/intel64:
/source/intel_parallel_XE//impi/4.1.1.036/intel64/bin:
/usr/lib64/qt-3.3/bin:
/home/username/perl5/bin:
/usr/NX/bin:
/usr/local/bin:
/bin:
/usr/bin:
/usr/local/sbin:
/usr/sbin:
/sbin:
/home/username/bin:
/home/username/bin

2014-07-11 11:45:09,390 DEBUG AWT-EventQueue-0 RController : 
Loaded jri library from /apps/source/R-3.0.2-mkl/lib64/R/library/rJava/jri/libjri.so

 

 

Problem resolved.

Path to R Home directory was set improperly.  In my environment was /apps/source/R-3.0.2-mkl”.  Needs to be  "/apps/source/R-3.0.2-mkl/lib64/R”.

Hm, it should disappear, though. What files do you have in /apps/source/R-3.0.2-mkl? Any .so?

apps/source/R-3.0.2-mkl
     bin
     include
     lib64
     share

Thanks, we found the problem. It will be fixed in 2.10.1. KNIME will show an error if you selected the wrong directory.