KNIME 2.6.3. GC overhead exceeded

Dear all,

 

I'm a chemist new to KNIME, intending to use the program for virtual screening in the ZINC database. After downloading a ZINC-sublibrary (an sdf-file of approximately 0.5Gb), I tried to process this file using flow chart below.  The program has proven to be prone to display the error below: GC overhead exceeded. This results in termination of the process.

My system is an Intel(R) Core(TM) i7 CPU processor 920 @ 2.67GHz, 6GB of RAM, 64-bit. I use Windows 7.

Each node uses "write tables to disc" as the memory setting.

Can anybody give suggestions to avoid this frustrating error (exceeding of GC overhead)? Is my system adequate to perform such tasks? If not, what are the recommended specs?

I'm trained as a pharmacist/chemist, not a computer scientist, so I would humbly ask to state your advise as if you were talking to a complete newbie.

Any help will be greatly appreciated

Arno Vermote

Hi Arno

 

Have you tried increasing your heap space? To do this: Open the knime.ini file in your KNIME installation folder and edit the line

 

-Xmx1024m (or it could be a different value) to something higher, you have 6GB RAM available so maybe try -Xmx3g (or -Xmx3072m). 

 

I don't know if this will fix a GC overhead issue though.

 

Another way to deal with memory issues I use to to do a chunk loop and operate incrementally over the data. Changing the memory management option on the memory expensive node to store the data to disk is also an option but this will slow down the workflow. When in  the dialog for the node look at the memory policy tab for this setting.

 

Cheers

 

Sam